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Introduction 

Cisco Router and Security Device Manager (SDM) is a web-based device management tool used in 

several Networking Academy Courses. CCNA Courses Discovery & Exploration include limited 

instruction and activities on SDM version 2.4, while CCNA Security includes a significant portion of 

instruction and activities on SDM version 2.5. This User Guide provides a reference for both versions 

including instructions on installation of the appropriate version for your course. 

Table 1 lists the corresponding SDM version for each curriculum. The listed versions of SDM 

executable files can be found on Academy Connection and Cisco Systems, Inc. as noted later in this 

document. Please use the appropriate version of SDM with the course and versions listed to ensure the 

most accurate match of screen output results during lab exercises. 

This document includes information on the SDM installation process as well as instructions to run SDM. 

If removal of SDM becomes necessary, this document also includes steps to remove SDM from the 

router or personal computer. 

Please note that Cisco Systems, Inc. announced the end-of -life for SDM. February 26, 2012 is the last 

day that Cisco Engineering may release any final software maintenance releases or bug fixes. The last 

day to receive service and support on SDM is February 28, 2014. The replacement product for SDM is 

Cisco Configuration Professional (CCP). Furthermore, the Integrated Services Routers Generation Two 

(ISR G2), 1900, 2900 and 3900 series, are not supported by SDM. These routers use Cisco 

Configuration Professional (CCP) for GUI based configuration.  

All the information regarding SDM included in this document is compiled from documents posted by 

Cisco Systems, Inc. The links to these documents can be located in the Further Resources section of this 

document.  

Downloading SDM executable files 

Academy Connection 

A Networking Academy instructor can log in and download the 

SDM executable zip files from Academy Connection. On the 

Academy Connection website, these zip files are located in the 

Equipment Information section under Resources or the classroom 

setup tab in the related curriculum.  

Equipment Information 

Once you have logged into Academy Connection, on the right side 

of the Instructor Home page under Resources, locate Equipment 

Information (Figure 1).  Then choose Lab Equipment List & 

Contact Info and the desired SDM Installer. Choose the related 

Table 1 SDM version for each curriculum 

 CCNA Discovery and Exploration 

Versions 4.0 & 4.1 

CCNA Security 

Version 1.0 

SDM Version 2.4 2.5 

 

 

Figure 1 Tools on the right side bar 

http://www.cisco.com/go/ccp
http://www.cisco.com/go/ccp
http://www.cisco.com/go/ccp
http://www.cisco.com/
http://www.cisco.com/
http://www.cisco.com/
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SDM version, for example, SDM version 2.5 if supporting CCNAS labs or 2.4 for Discovery and 

Explorations labs.  Download the zip file to a desired location. 

Classroom Setup Tab 

SDM executable zip files can also be found in the 

Classroom Setup tab. After logging into Academy 

Connection website as an instructor, choose Tools 

(Figure 1) on the right side bar on the Instructor 

Home page. 

After clicking Tools, find the section labeled Find 

Curriculum & Instructional Tools (Figure 2). 

Then choose the desired curriculum and click Find 

Tools. On the next page, choose the Classroom 

Setup tab and locate the related SDM zip file. 

Click on the link to the zip file and save the zip file 

in a desired location on the PC. 

Click-Paths to Download Corresponding SDM versions 

Equipment Information: Equipment Information > Lab Equipment List & Contact Info > desired 

SDM Installer 

CCNA Discovery, SDM v2.4: Choose Tools > Select Curriculum > CCNA Discovery > Select 

Course.  Choose any CCNA Discovery Course and the version. Click Find Tools.  Choose 

the Classroom Setup tab and locate SDM v2.4 installer’ 

CCNA Exploration, SDM v2.4: Choose Tools > Select Curriculum > CCNA Exploration >  

Select Course . Choose any CCNA Exploration Course and the version.  Click Find 

Tools.  Choose the Classroom Setup tab and locate SDM v2.4 installer. 

CCNA Security, SDM v2.5: Choose Tools > Select Curriculum > CCNA Security > Select 

Course  > CCNA Security and the version . Click Find Tools.  Choose the Classroom 

Setup tab and locate SDM v2.5 installer. 

Cisco Website 

A Network Academy instructor with a privileged Cisco Connection Online (CCO) account can 

download SDM from the Cisco website. 

Router Requirements 

The following section lists only the system requirements in Academy curricula for use with Cisco 

equipment sold through the Academy. For a complete list of supported IOS images, routers, adapters, 

cards, and network modules, please visit the following link for the release notes provided by Cisco 

Systems, Inc. 

http://www.cisco.com/en/US/products/sw/secursw/ps5318/prod_release_notes_list.html 

Supported Routers 

SDM supports many routers including the ISR G1 models used by Networking Academy. These models 

include the 1841, 2801 and 2811. SDM does NOT support the ISR G2 routers (1900, 2900, and 3900). 

 

Figure 2 Find Curriculum & Instructional Tools 

http://www.cisco.com/en/US/products/sw/secursw/ps5318/prod_release_notes_list.html
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G2 models use CCP as the preferred GUI configuration tool. Table 2 lists only the Academy-bundled 

routers and available IOS images from CCO for use with SDM v2.4 and v2.5. For a complete list of 

routers supported by each version of SDM, please visit 

http://www.cisco.com/en/US/products/sw/secursw/ps5318/prod_release_notes_list.html 

Cisco's Feature Navigator or Software Advisor can also provide this information by searching on 

feature, image, or platform. 

Adapters Cards and Network Modules 

SDM supports a variety of adapters, cards, and network modules. Table 3 lists all the supported 

interfaces sold through the Academy. SDM is compatible with HWIC-4ESW, WIC-1B-ST, WIC-1T, 

WIC-2A/S and WIC-2T cards. 

Memory Requirements 

Table 2 SDM Supported Cisco Routers and IOS Versions 

SDM Supported Routers Available Cisco IOS Versions 

Cisco 1721, 1751, and 1760  12.4(3) or later 

 12.4(2)T or later 

Cisco 1841  12.4(2)T or later 

 12.4(3) or later 

 15.0(1)M or later 

 15.1(1)T or later 

Cisco 2611XM, 2620XM, 2621XM, and 2691  12.3(8)T or later 

 12.4(3) or later 

 12.4(2)T or later 

Cisco 2801 and 2811  12.4(2)T or later 

 12.4(3) or later 

 15.0(1)M or later 

 15.1(1)T or later 

Table 3 List of supported interfaces sold through the Academy 

SDM Supported Router 

Interfaces 
Part Numbers 

WAN Interfaces (WICs) WIC-1T, WIC-2A/S, WIC-2T, WIC-1B-S/T 

High speed WICs (HWICs) HWIC-4ESW 

http://www.cisco.com/en/US/products/sw/secursw/ps5318/prod_release_notes_list.html
http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp
http://tools.cisco.com/Support/Fusion/FusionHome.do
http://www.cisco.com/cisco/software/release.html?mdfid=270676014&flowid=7305&softwareid=280805680
http://www.cisco.com/cisco/software/release.html?mdfid=268437927&flowid=7257&softwareid=280805680
http://www.cisco.com/cisco/software/release.html?mdfid=270663620&flowid=7302&softwareid=280805680
http://www.cisco.com/cisco/software/release.html?mdfid=279119622&flowid=7351&softwareid=280805680
http://www.cisco.com/cisco/software/release.html?mdfid=277801007&flowid=7320&softwareid=280805680
http://www.cisco.com/cisco/software/release.html?mdfid=277801008&flowid=7323&softwareid=280805680
http://www.cisco.com/cisco/software/release.html?mdfid=277801009&flowid=7326&softwareid=280805680
http://www.cisco.com/cisco/software/release.html?mdfid=275618046&flowid=7317&softwareid=280805680
http://www.cisco.com/cisco/software/release.html?mdfid=279316777&flowid=7545&softwareid=280805680
http://www.cisco.com/cisco/software/release.html?mdfid=279120799&flowid=7537&softwareid=280805680
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Table 4 lists the minimum router memory requirements to successfully run SDM. The table only lists the 

requirements for SDM versions 2.4 and 2.5. 

PC System Requirements 

SDM can be run from a router via a web browser or a small executable installed on the PC. This section 

documents the PC requirements for running SDM properly from either location. 

SDM is designed to run on a personal computer that has a Pentium III or faster processor. SDM can be 

run on a PC using any of the following operating systems for SDM versions 2.4 and later: 

 Microsoft Windows XP Professional 

 Microsoft Windows 2003 Server (Standard Edition) 

 Microsoft Windows 2000 Professional with Service Pack 4 (Windows 2000 Advanced Server is 
not supported) 

 Microsoft Windows Vista (Business Edition) 

Note: A Windows PC is necessary to install SDM. After SDM has been installed on the router, a PC 

with network connectivity to the router can access SDM from a web browser by using the router IP 

address or hostname. 

Minimum Screen Resolution 

Cisco SDM requires a screen resolution of at least 1024 x 768. 

Web Browser Versions and Java Runtime Environment Versions 

SDM version 2.4 or later can be used with the following browsers: 

 Netscape 7.1 and 7.2 

 Netscape 9.0 (supported only in version 2.5) 

 Internet Explorer version 5.5 and later versions 

 Firefox 1.0.6 and later versions 

SDM uses SUN Java Runtime Environment (JRE) version 1.4.1 or later integrated into the web browser. 

The Java versions required to run SDM as documented by Cisco Systems are listed in Table 5. 

Table 4 Memory Requirements for Routers and PC to Support SDM 

Applications Version 2.4 Version 2.5 

Cisco SDM (Flash Memory on the Router) 6.97 MB 7.63 MB 

Cisco SDM Express (Flash Memory on the Router) 2.04 MB 2.43 MB 

Cisco SDM installed on a PC 7.5 MB 8.14MB 

Wireless Management Application (in addition to Cisco SDM 

memory requirements on the Router) 
2 MB 2.13 MB 
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Links to Download or Verify Java 

Download the older versions of Java: http://java.sun.com/products/archive/ 

Testing and verifying the installed version of Java: http://www.java.com/en/download/testjava.jsp 

Router Preparation 

The following section outlines the steps to prepare the router to install and run SDM. The router 

establishes network communications with a Windows PC during SDM installation. HTTP/HTTPS is 

also enabled for web browser access. Finally, privileged user accounts are setup for router access using 

SDM. 

Steps to Setup Router for SDM access 

Step 1) Configure the router Fa0/0 IP address  

(This is the interface that a PC will connect to using a web browser to bring up SDM. An SDM router may 

require connection to a different port in order to access SDM. The IP address in this example is for 

reference only. Any network addresses will work as long as there is network connectivity between the router 

and PC.) 

Router(config)# interface Fa0/0 

Router(config-if)# ip address 10.10.10.1 255.255.255.248 

Router(config-if)# no shutdown 

Step 2) Enable the HTTP/HTTPS server of the router 

Router(config)# ip http server 

Router(config)# ip http secure-server 

Router(config)# ip http authentication local 

Step 3) Create a user account with privilege level 15 (enable privileges) 

Router(config)# username <username> privilege 15 password <password> 
Replace <username> and <password> with the username and password that was chosen by the user. 

Step4) Configure SSH and Telnet for local login and privilege level 15 

Router(config)# line vty 0 4 

Router(config-line)# privilege level 15 

Router(config-line)# login local 

Router(config-line)# logging synchronous 

Router(config-line)# transport input telnet 

Router(config-line)# transport input telnet ssh 

SDM Installation 

Table 5 Java Requirement for SDM 

SDM Version Supported JRE Versions 

2.4 JRE 1.4.2_08, JRE 1.5.0_06, JRE 1.5.0_07, JRE 1.5_09 

2.5 JRE 1.4.2_08, JRE 1.5.0_06, JRE 1.5.0_07, JRE 1.5_09, JRE 1.6.0_02, 

JRE 1.6.0_03 

http://java.sun.com/products/archive/
http://www.java.com/en/download/testjava.jsp
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SDM can be installed on a Windows PC, a SDM-supported router (see Supported Routers for a list of 

routers sold by the Academy) or both a Windows PC and a router. The option to install SDM on both a 

computer and a router allows the user the option to launch SDM from a Windows computer or from any 

PC via the web browser. All options require network connectivity to the router, HTTP/HTTPS enabled 

on the router, and a compatible Java version running on the computer. 

The following is a sample installation procedure for SDM version 2.4 on a Windows computer or router. 
The procedure is similar for other versions of SDM. When the file is unzipped, the folder SDM-V24 will 

be created in the user-defined location. In this example, the executable file setup is found in the SDM-

V24 folder, and the setup process is started by double-clicking on the setup.exe icon (Figure 3). Once all 

the permission issues are satisfied , the Cisco SDM-InstallShield wizard appears (Figure 4). The 

installation process can begin once the license agreement is accepted (Figure 5). 

 

Figure 3 In the SDM-V24 folder, double click the setup.exe file to start the SDM installation process 

 

Figure 4 Click Next on the Welcome Screen to continue. 



 

SDM User's Guide Page 7 of 21 Revised on April 8, 2011 

After accepting the license agreement, the user has three choices for SDM installation (Figure 6): 

 This Computer (Here): SDM is run from the local Windows PC that meets the memory and 

hardware/software requirements listed earlier. The user can access the router by using this locally 
installed SDM executable to connect to a target router. 

  Cisco Router: SDM is installed in flash memory of a supported router. (Please see Supported 

Routers for a list of supported routers sold by the Academy.) This option allows the user to 

access the router that is using SDM from any PC that has a compatible web browser. 

 Both (computer and router): The user can install SDM on both a Windows PC and the flash 

memory of a supported router. (See Supported Routers) This option allows the user to launch 

SDM from the PC or alternately from any PC by using a compatible browser. Only routers with 

the locally installed version of SDM can be accessed by PCs using the browser method. 

 
Figure 5 Continue with the installation, the use must accept the license agreement by clicking Next. 

 

Figure 6 Choose an installation option and click Next. 
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Installation on a Local Windows PC 

Installing SDM on a Windows PC is similar to installing other applications on a PC. The installation 

wizard will guide the users through all the steps. The user decides the destination folder for SDM 

installation (Figure 7) and clicks Next. The installation starts when the user clicks Install (Figure 8). 

When the installation is finished, Cisco Systems is listed under Programs in the Start Menu and a short 

cut to Cisco SDM may appear on the desktop. SDM can be started by choosing Cisco SDM under the 

submenus for Cisco Systems in the Start Menu or double-clicking the desktop icon (if it was installed). 

 

Figure 7 Click Choose the destination folder 

 

Figure 8 Click Install to commence the SDM installation process for a Windows PC. 
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Installation on the Flash Memory of a Router 

Once the router preparation is finished (see Router Preparation), the installation can be started 

by executing the setup.exe file in the SDM-v24 folder on a Windows PC. The Cisco SDM-

InstallShield wizard will start after all the security and licensing issues are addressed. The user 

clicks Next to continue. The user must accept the license agreement to continue with the 

installation (Figure 9). 

In the Install Option dialog box, choose Cisco Router to install SDM on the flash memory of the router 
(Figure 10). In the Router Authentication dialog box, input the IP address or hostname of the router and 

the username of a privilege level 15 username & password pair that was previously configured on the 

 

Figure 9 To continue with the installation, the user must accept the license agreement by clicking Next. 

 

Figure 10 Choose Cisco Router and click Next. 
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router in the Router Preparation step. Click Next to start the SDM installation on the router (Figure 11). 

It could take a few minutes for the Windows PC to connect to the router. After the wizard connects to 

the router, it prompts the user for the type of SDM installation: Typical or Custom. Most likely, Typical 

is an adequate choice. The Installation Wizard prompts the user to choose the SDM components for 

installation. The user should verify that there is enough space available on flash to install all the desired 

components (Figure 12). If space is limited, the user can choose not to install Cisco SDM Express. Cisco 

SDM Express is optional in the general function of SDM. Cisco SDM Express is only used for the initial 

router setup or after restoring the router to the default factory settings. Once the components are 

selected, the Installation Wizard is ready to install SDM on the router. The user clicks Next to continue 

with the installation. When the user is ready to install SDM on the router, the user clicks Install to start 

installing the application. After SDM is installed on the router, a user can access the router by using a 

web browser if the user has the right credentials and network access to that router. 

 

Figure 11 Input the IP address of the router, privilege level 15 username and password 

 

Figure 12 Verify available router flash memory for all desired components and click Next to continue. 
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Running SDM from a PC 

After the SDM installation is completed, SDM can be launched from the short cut on the Desktop or in 

the Start menu > Programs >  Cisco Systems. Once SDM is launched, a dialog box prompts for the IP 

address or the hostname of the desired router (Figure 13). 

Note: If the command ip http secure-server was issued for the router, the user can choose to enable 

HTTPS by clicking on the check box next to “This device has HTTPS enabled and I want to use it” (see 

Router Preparation). 

Once the SDM is launched, an Authentication Required dialog box prompts for username and password 

(Figure 14). The username and password pair was either configured by the user from the command line 

interface or from the factory default username cisco and password cisco. Once the correct credentials are 
accepted, SDM launches and allows access to the router. If SDM fails to launch at this point, there are a 

few issues to consider. Check that all the security issues have been addressed. Also consider whether the 

pop-up blocker in the web browser is disabled for the router IP address or hostname. As an example, in 

Internet Explorer, the popup blocker can be deactivated by going to Tools >  Popup Blocker. In this 

menu, the user can choose to turn off the popup blocker entirely or disable the popup blocker for certain 

IP addresses or hostnames. After the popup blocker has been disabled, the user may need to restart SDM 

and the web browser. 

 

Figure 13 Input the router IP address or hostname to launch SDM. 

 

Figure 14 Input username and Password, such as username cisco and password cisco. 
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Note: If SDM does not start or function properly, please verify the Java version. (see Web Browser 
Versions and Java Runtime Environment Versions) 

Running SDM from a Router 

To run SDM from a router, a computer must have network connectivity to the router using a web 

browser. In the web browser, input the router IP address or hostname. Once SDM starts, SDM prompts 

if the user wants to use HTTPS to communicate with the router. This occurs if HTTPS is enabled on the 

router. To enable HTTPS, the command ip http secure-server must be configured on the router. The 

user can use HTTPS by choosing OK to continue with SDM using HTTPS (Figure 15). Next, SDM will 

prompt the user for username and password (Figure 16). When logging in, use either the username and 

password pair that was configured on the router when setting up the router for SDM installation (see 

Router Preparation) or the default factory username cisco and password cisco. SDM will not start if the 

popup blocker is active for the router IP address or hostname. For example,  in Mozilla Firefox, the 

popup blocker can be disabled by going to the Tools  >  Options > Content tab. In this tab, the user can 

choose to turn off popup blocker entirely or disable popup blocker for certain IP addresses or hostnames. 

After the popup blocker has been disabled, the user may need to restart the web browser to access SDM. 

Note: If SDM does not start or function properly, please verify the Java version. (see Web Browser 

Versions and Java Runtime Environment Versions) 

SDM Express 

SDM Express is a component of SDM that performs basic initial router configuration from a web 

browser using the router IP address. SDM Express is only available when the router is in the original 

 

Figure 15 If ip http secure-server is issued for the router, the user can choose to use HTTPS to 

communicate with the router. 

 

Figure 16 Input username and password with the privileges to access the router. 
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factory settings (see Further Resources for a sample router configuration). The original factory network 

settings for a SDM-supported router are listed below in Table 6. 

Once the router has been configured by the user, SDM is executed instead of SDM Express when a web 

browser is used to access the router. 

Restoring Router to Default Factory Settings 

SDM can restore the router to default factory settings. A web browser with the router IP address or 

hostname is used to access the SDM application installed on the router. 

After SDM is launched, under the File menu, choose Reset to factory default. Another way to reset the 

router is to click on the Configure button and then choose Additional Tasks on the left sidebar of the 

Configure page. Then choose Reset to Factory default under the Configuration Management folder. 

It is important to note the instructions in the dialog box (Figure 17). During the process of restoring the 

router to default factory settings, the current running configurations on the router will be replaced with a 

default configuration (see Further Resources for a sample). The running configurations of the user will 

be erased unless they are saved to a PC or other storage devices (Step 1 in Figure 17). When ready, click 

on the Reset Router button. A Warning dialog box will appear and click Yes to continue to reset the 

router. 

While the route is resetting, SDM will need to be closed and network connectivity to the router will also 
be lost. Once the router is reset, SDM can be opened again using the default factory settings. After the 

router has been reset, the IP address on the PC has to be changed to an available address in 

10.10.10.0/29 network to reconnect to the router. To access SDM again on the router, open a web 

browser to http://10.10.10.1/ and log on with the username cisco and password cisco. When the 

credentials are verified, SDM Express will now open for initial router configurations. Once the router is 

configured, SDM Express will not launch again until the router is restored to default factory settings. 

SDM will launch in place of SDM Express for normal maintenance. 

Table 6 Default factory settings for SDM access 

 Default Factory Settings 

FastEthenet0/0 IP Address / netmask 10.10.10.1 / 255.255.255.248 

Username /  password cisco / cisco 
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Figure 17 Restore Router to Factory Default. 
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Uninstalling Cisco SDM Files 

Remove SDM from Windows PC 

To remove Cisco SDM version 2.1 or later from a PC: 

Step 1: Click Start > Program > Cisco Systems > Cisco SDM > Uninstall to launch the 

Uninstall program. 

Step 2: When the message “Do you want to remove the selected applications and all of its 

features?” appears, click Yes. 

Step 3: When the Uninstallation Complete screen is displayed, click Finish. 

Remove SDM files from the Router 

When removing Cisco SDM from flash memory or from other router disk file system, the user logs into 

the router and completes the following steps in EXEC mode: 

Step 1: Change to the directory in which the Cisco SDM files are located. If the router has a flash 

file system, use the following command: 

router# cd flash: 

Step 2: Use the delete command to remove all Cisco SDM files. 

The example below deletes the file sdm.tar:. 

router# delete sdm.tar 

Delete filename [sdm.tar]? 

Delete flash:sdm.tar? [confirm] 

Press Return to confirm the deletion. 

To delete all files with the same extension (.tar): 

router# delete *.tar (This will delete all the files with .tar extension) 

Step 3 Reclaim memory space by using the squeeze flash: command: 

router# squeeze flash: 

It is not necessary to use the squeeze flash: command on DOS-based file systems. 
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Table 7 displays a sample list of SDM 2.4 related files that are loaded on the router file system. Once 

these files are removed from the router file system, SDM is no longer accessible from a web browser. 

End of Sale and End of Life of SDM 

Cisco Systems, Inc. has announced the end-of-sale and end-of-life for SDM on August 28, 2010. The 

last day to order SDM is February 26, 2011. February 26, 2012 is the last day that Cisco Engineering 

may release any final software maintenance releases or bug fixes. The last day to receive service and 

support on SDM will be February 28, 2014. 

The replacement product for SDM is Cisco Configuration Professional (CCP). More information and 
software download can be found at the following location: http://www.cisco.com/go/ccp 

  

Table 7 Sample list of SDM related files and descriptions of the function of the files 

Filename Size Description 

common.tar 1.11 MB Cisco SDM and Cisco SDM Express support file 

es.tar 840 KB Cisco SDM Express application file 

home.shtml 1.01 KB Cisco SDM and Cisco SDM Express support file 

home.tar 110 KB Cisco SDM and Cisco SDM Express support file 

sdmconfig-modelnum.cfg 
Example for 1841 Router: 
sdmconf-18xx.cfg 

2.0 KB Default configuration file 

sdm.tar 5.75 MB Cisco SDM application file 

sdmips.sdf Variable 
Files created when Cisco SDM is used to modify Cisco IOS IPS 

signatures 

securedesktop-ios-3.1.1.45-k9.pkg 1.61 MB Cisco Secure Desktop client software for SSL VPN client. 

sslclient-win-1.1.3.173.pkg 406 KB Full tunnel client software for SSL VPN clients 

wlanui.tar 406 KB Wireless Application 

128MB.sdf 515 KB Signature Definition File (SDF) used by Cisco IOS IPS 

wlanui.tar 406 KB Wireless Application 

http://www.cisco.com/go/ccp
http://www.cisco.com/go/ccp
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Troubleshooting 

Enabling Desired Java Versions 

If the PC is running unsupported Java versions, SDM will not function properly. For example, the user 

cannot select Additional Tasks in the Configure page or select desired check boxes. To fix this, the user 

enables only the SDM supported Java versions in the Java Control Panel. The Java Control Panel can be 

accessed through the Control Panel (Figure 18). If the Java icon cannot be found in the Control Panel, 

Java probably has not been installed on the system. Go to the Java website to download and install Java. 

Please see Web Browser Versions and Java Runtime Environment Versions for SDM supported Java 

versions. Once the Java Control Panel opens, choose the Java tab and then click View to manage the 

Java Runtime versions and settings (Figure 19). In the Java Runtime Environment (JRE) Settings dialog 

box, the user can choose to enable only the SDM-supported Java versions by deselecting the 

unsupported version or versions (Figure 20).  The user then clicks OK to continue. When only the SDM-

supported Java version(s) are enabled, the user closes all web browsers and SDM for the new JRE 

settings to take effect.  

Note: Only one supported version of JRE is necessary for SDM to function properly. When the user 

opens SDM or a web browser that refers to the router IP address or hostname, the user may receive a 

 

Figure 18 Java Control Panel can be found in the computer Control Panel. 

 

Figure 19 Java Control Panel and select Java tab: click View to manage the Java versions 

http://java.sun.com/products/archive/
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Java Security Warning dialog box. The  user clicks Run to allow the use of an earlier version of Java 

(Figure 21). 

 

Java Stack Overflow 

To resolve Java stack overflow problems associated with SDM, go to Start > Control Panel > Java --> 

Java Tab . Click View on the Java Applet Runtime Settings section. Then in Java Runtime 

Parameters, type -Xmx256m (see Figure 19 and Figure 20). If Java cannot be found in the Control 

Panel, Java probably is not installed on the system. Go to the Java website to download and install SDM 

supported Java versions. Please see Web Browser Versions and Java Runtime Environment Versions for 

SDM supported Java versions. 

For Windows XP with SP2 users 

When Cisco SDM is installed on a PC running Windows XP with Service Pack 2, Internet Explorer may 

display HTML source code when attempting to launch Cisco SDM. To fix this problem, go to Tools > 

Internet Options > Advanced. Then scroll to the Security section, check Allow Active Content to 

Run in Files on My Computer, and click Apply. Then re-launch Cisco SDM. 

 

Figure 20 JRE settings to enable only the SDM supported versions. 

 

Figure 21 Click Run to use an earlier version of Java. 

http://java.sun.com/products/archive/
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Further Resources 

SDM Overview and Support Information 

http://www.cisco.com/go/sdm 

http://www.cisco.com/en/US/prod/collateral/routers/ps5318/product_data_sheet0900aecd800fd118.html 

Release Notes for all available SDM versions 

http://www.cisco.com/en/US/products/sw/secursw/ps5318/prod_release_notes_list.html 

SDM Download Locations 

If you are an instructor in a Cisco Network Academy, SDM versions 2.4 and 2.5 can be 
downloaded from cisco.netacad.net. 

Click-Path to Download Corresponding SDM versions 

Equipment Information: Equipment Information > Lab Equipment List & Contact Info > desired 

SDM Installer 

CCNA Discovery, SDM v2.4: Choose Tools > Select Curriculum > CCNA Discovery > Select 

Course.  Choose any CCNA Discovery Course and the version. Click Find Tools.  Choose 

the Classroom Setup tab and locate SDM v2.4 installer’ 

CCNA Exploration, SDM v2.4: Choose Tools > Select Curriculum > CCNA Exploration >  

Select Course . Choose any CCNA Exploration Course and the version.  Click Find 

Tools.  Choose the Classroom Setup tab and locate SDM v2.4 installer. 

CCNA Security, SDM v2.5: Choose Tools > Select Curriculum > CCNA Security > Select 

Course  > CCNA Security and the version . Click Find Tools.  Choose the Classroom 

Setup tab and locate SDM v2.5 installer. 

A Network Academy instructor with a privileged Cisco Connection Online (CCO) account can 
download SDM from www.cisco.com. 

Feature Navigator 

http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp 

Software Advisor 

http://tools.cisco.com/Support/Fusion/FusionHome.do?mySession=144433&myStep=8 

Links to Download or Verify Java 

Download the latest version of Java: http://java.com/en/dformat ownload/manual.jsp 

Download the older versions of Java: http://java.sun.com/products/archive/ 

Testing and verifying the installed version of Java: http://www.java.com/en/download/help/testvm.xml  

Cisco Configuration Professional 

Information and software download: http://www.cisco.com/go/ccp 

http://www.cisco.com/go/sdm
http://www.cisco.com/en/US/prod/collateral/routers/ps5318/product_data_sheet0900aecd800fd118.html
http://www.cisco.com/en/US/products/sw/secursw/ps5318/prod_release_notes_list.html
http://cisco.netacad.net/
file://tsclient/data/Unicon/SDM/www.cisco.com
http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp
http://tools.cisco.com/Support/Fusion/FusionHome.do?mySession=144433&myStep=8
http://java.com/en/dformat
http://java.com/en/dformat
http://java.sun.com/products/archive/
http://www.java.com/en/download/help/testvm.xml
http://www.cisco.com/go/ccp
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Sample Default Startup Configuration File for Cisco Router and Security Device Manager 

!  The default startup configuration file for Cisco Router and Security Device Manager (SDM) 

!  DO NOT modify this file; it is required by SDM as is for factory defaults 

!  Version 1.0 

hostname yourname 

logging buffered 51200 warnings 

username cisco privilege 15 secret 0 cisco 

ip domain-name yourdomain.com 

interface FastEthernet0/0 

 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$ 

 ip address 10.10.10.1 255.255.255.248 

 no shutdown  

ip http server 

ip http access-class 23 

ip http secure-server 

ip http authentication local 

ip http timeout-policy idle 60 life 86400 requests 10000 

access-list 23 permit 10.10.10.0 0.0.0.7 

banner login ^ 

----------------------------------------------------------------------- 

Cisco Router and Security Device Manager (SDM) is installed on this device.  

This feature requires the one-time use of the username "cisco"  

with the password "cisco". The default username and password have a privilege level of 15. 

Please change these publicly known initial credentials using SDM or the IOS CLI.  

Here are the Cisco IOS commands. 

username <myuser>  privilege 15 secret 0 <mypassword> 

no username cisco 

Replace <myuser> and <mypassword> with the username and password you want to use.  

For more information about SDM please follow the instructions in the QUICK START  

GUIDE for your router or go to http://www.cisco.com/go/sdm  

----------------------------------------------------------------------- 

^ 

line con 0 

 login local 

line vty 0 4 

 access-class 23 in 

 privilege level 15 

 login local 

 transport input telnet 

 transport input telnet ssh 

line vty 5 15 

 access-class 23 in 

 privilege level 15 

 login local 

 transport input telnet 

 transport input telnet ssh 

 

!  End of SDM default config file 

end 


